🐛 Align and distribute section not appearing

I’ve seen this a few times recently: I paint select a few cards, and the context menu doesn’t contain the align and distribute section. In the log, I see a pair of errors.

I was able to isolate the problem some more:

  1. Create card A.
  2. Create card B.
  3. Paint from A through B.

However, as I was about to publish this, it is not 100%. I can break it maybe 25% of the time :slight_smile:

does the orientation/position of cards A and B matter to trigger this error?

I can’t say comprehensively, but here’s what I tried…

  • The first A ↔ B with connection worked fine.
  • A B triggered the bug
  • C D triggered the bug
  • E F triggered the bug

In all these cases, I painted downwards.

It seems that after I see the bug, subsequent openings of the context menu do not trigger the bug.

1 Like

I’m not able to reproduce but i’ll keep an eye on the issue. if you have this problem again where selecting multiple cards doesn’t show the alignment options, try dragging one of the selected cards and let me know if both move as they should

Yes, the cards move as they should. And I continue to see that error in the console:

1 Like

v helpful thx

@bentsai just wanted to check in before i investigate this some more, are you still having this issue?

I’ve not tried to explicitly repro, but I haven’t see it in a long while. So I guess the answer is no:)

1 Like