Bug: Bulk connect to one card doesn't seem to work

I usually like to group multiple cards to one “topic card”, my main workflow is to create TODO cards, and copy/paste them over to my daily journal which has a “TODOs” card. when i paste them to the new daily journal, i’ll highlight all the todos and try to link them to the “TODOs” card. but the last couple days when I do that workflow, the bulk lines disappear and a floating, context-less “remove” option shows up

steps to reproduce:

  • create four cards
  • highlight three of them
  • select the “connector” button one one of the highlighted cards, and drag it to the non-highlighted cards


  • the three cards are now linked to the fourth card.


  • the connections disappear and don’t show up, and a phantom “remove” option shows up.

Screen Shot 2022-08-23 at 11.23.26 AM


hmm i’m not able to repro the connections disappearing , can you try signing out and back in again and see if that fixes it? If it doesn’t can you let me know if you see any errors in the browser web console?

1 Like

I’m seeing this too. Tried logging off and back on and still experiencing it.

Highlight three cards → drag connector from one of the three → drop on a different card → no connections, and dialog with just Remove appears.

Reproducible everytime for me. Can’t get it to work at all. On iPad.


strangely enough… I can’t reproduce now… but it was happening consistently for me. I was copy/pasting it between daily journals, i wonder if that had something to do with it?

I’m also usually using the mac app if that helps narrow it down. If it happens again i’ll peek at the dev tools there


Also seems to be mostly resolved on my end.

Still get the pop-up with just the Remove button after making the multi-connection though.


i have a fix for this, it’ll ship with the next inbox release

1 Like

in the meantime, this bug only occurs if there are no connections in the space and the first time you’re making a connection you’re doing so from multiple cards. the hack is to make sure there’s a single connection in the space first.

Kind of a weird bug :slight_smile:


Ah nice thanks! that’s easy enough workaround for now :stuck_out_tongue: Thanks for such a quick turnaround time! I’m a big fan of kinopio and I tell as many people as I can about it.


I appreciate that , thanks !

Fix released